
  






<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.dailyadvance.com/content/tncms/live/" />
<meta name="tncms-access-version" content="2021-11-02 15:04:21" />
<meta name="tncms-access-criteria" content="{&quot;3743708e-5c06-11eb-9e47-1bc8dc2c2725&quot;:[&quot;67a36f7a-5bf4-11eb-9e47-d3b949e2656b&quot;],&quot;332b010e-b432-11eb-ae08-2b1722956715&quot;:[&quot;8f77d30c-0c98-11eb-ae08-f3b1544458e5&quot;,&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;7963fd5a-827e-11eb-9e47-db7969f1494a&quot;:[],&quot;dacbecc0-827d-11eb-9e47-03d3722f19a5&quot;:[],&quot;75816a34-b432-11eb-ae08-370d3a6810a0&quot;:[&quot;8f77d30c-0c98-11eb-ae08-f3b1544458e5&quot;,&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;af44995c-827e-11eb-9e47-f7c7aaf3f519&quot;:[],&quot;c85e87a0-827d-11eb-9e47-9b4b834c4a2a&quot;:[],&quot;b2bbbbe8-b432-11eb-ae08-035f061bbae0&quot;:[],&quot;5ced5d6a-827e-11eb-9e47-7741fa8772a6&quot;:[],&quot;39be7aa6-5c07-11eb-9e47-7331f5eb6124&quot;:[],&quot;0d26d374-b433-11eb-ae08-e31c555560c6&quot;:[&quot;8f77d30c-0c98-11eb-ae08-f3b1544458e5&quot;,&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;d02f9ca2-827e-11eb-9e47-5f8fc6cd195e&quot;:[&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;545c8ca8-827d-11eb-9e47-b3cb9adb0946&quot;:[&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;400a5b80-b433-11eb-ae08-af1e647440b8&quot;:[&quot;8f77d30c-0c98-11eb-ae08-f3b1544458e5&quot;,&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;e6d521e8-827e-11eb-9e47-dff48a882828&quot;:[&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;73dccbf6-827d-11eb-9e47-dbd26cc8fe63&quot;:[&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;a8d6d86e-b433-11eb-ae08-6fdb3cfed0bb&quot;:[&quot;8f77d30c-0c98-11eb-ae08-f3b1544458e5&quot;,&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;0fe7313e-827f-11eb-9e47-5b7ee0076aa7&quot;:[&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;9efb49a2-827d-11eb-9e47-471125b3e755&quot;:[&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;7c11913e-b433-11eb-ae08-a7dfbce0d157&quot;:[&quot;8f77d30c-0c98-11eb-ae08-f3b1544458e5&quot;,&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;fd2e72d2-827e-11eb-9e47-83766b32da24&quot;:[&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;],&quot;8aa2aaea-827d-11eb-9e47-b7e019d86e1f&quot;:[&quot;a36e9864-0c98-11eb-ae08-03144b4cd286&quot;]}" />
<meta name="tncms-criteria-ids" content="67a36f7a-5bf4-11eb-9e47-d3b949e2656b,8f77d30c-0c98-11eb-ae08-f3b1544458e5,a36e9864-0c98-11eb-ae08-03144b4cd286" />
<meta name="tncms-access-asset-app" content="editorial" />
<meta name="tncms-access-asset-id" content="75cb564c-8988-5311-a1c0-053adacfebef" />
<meta name="keywords" content="local" />
<meta name="news_keywords" content="local" />
<meta name="description" content="CURRITUCK &mdash; Royal Farm&rsquo;s world famous fried chicken is coming to Currituck." />
<meta name="author" content="Paul Nielsen Staff Writer" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="googlebot" content="noarchive" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.dailyadvance.com/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?crop=905%2C475%2C4%2C0&amp;resize=905%2C475&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="905" />
<meta property="og:image:height" content="475" />
<meta property="og:title" content="Royal Farms plans to build first NC store in Grandy" />
<meta property="og:description" content="CURRITUCK &mdash; Royal Farm&rsquo;s world famous fried chicken is coming to Currituck." />
<meta property="og:site_name" content="dailyadvance.com" />
<meta property="og:section" content="Local News" />
<meta property="article:publisher" content="https://www.facebook.com/thedailyadvance" />
<meta property="tncms:subs" content="3.0" />
<meta property="tncms:ads" content="lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.c58a1beaa3640fa94c3db09673c4d95c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.2ce6292643f5129895871a2478a4614d.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.feb84265ed22ec1b578ffb91ddb31be4.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Amiri:400,700|Catamaran:400,700|Vollkorn:400,700,900|Playfair+Display+SC:900"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/tntslider.f0c083d16d9ead5fda668c00e19f96ba.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.60.5"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"mobile_pattern","style":"default","path":"\/news\/local","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"asset":{"author":"Paul Nielsen\nStaff Writer","presentation":null,"start_hour":"16","id":"75cb564c-8988-5311-a1c0-053adacfebef","app":"editorial","ga_page":"\/news\/local\/article_75cb564c-8988-5311-a1c0-053adacfebef.html"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":296},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.60.5"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"mobile_pattern","style":"default","path":"\/news\/local","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"asset":{"author":"Paul Nielsen\nStaff Writer","presentation":null,"start_hour":"16","id":"75cb564c-8988-5311-a1c0-053adacfebef","app":"editorial","ga_page":"\/news\/local\/article_75cb564c-8988-5311-a1c0-053adacfebef.html"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":296},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PLNLF2D');})();</script>
<script src="https://tags.crwdcntrl.net/c/16235/cc.js?ns=_cc16235" id="LOTCC_16235"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc16235.add('tp', 'TNNW');
		_cc16235.add('act', ' User Login');
		_cc16235.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc16235.bcp();
</script>

<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script>/*<![CDATA[*/ window.TNCMS = window.TNCMS || {};window.TNCMS.Access = window.TNCMS.Access || [];(function (callback) { var oScript; var oStorage; try { oStorage = JSON.parse(sessionStorage.getItem('tncms.dmp.audiences')); if (!oStorage || !oStorage.audiences || !oStorage.expired) { throw "Not in session storage"; } if (oStorage.expired < new Date().getTime()) { sessionStorage.removeItem('tncms.dmp.audiences'); throw "Cache is expired"; } callback(oStorage.audiences); } catch(oException) { if (!window.tncms_siteaud) { window.tncms_siteaud = null; } oScript = document.createElement('script'); oScript.onerror = function() { callback([]); }; oScript.onload = function() { try { var oResult = { audiences:[], expired: new Date().getTime() + 86400000 }; if (!window.tncms_siteaud) { return; } for(var nIdx = 0; nIdx < window.tncms_siteaud.Profile.Audiences.Audience.length; nIdx++) { var sAbbr = window.tncms_siteaud.Profile.Audiences.Audience[nIdx].abbr; oResult.audiences[oResult.audiences.length] = sAbbr; } oResult.audiences.sort(); sessionStorage.setItem('tncms.dmp.audiences', JSON.stringify(oResult)); } catch(oException) { if (console && console.warn) { console.warn('Failed to add behaviors to session storage'); } } callback(oResult.audiences); }; oScript.setAttribute('async', true); oScript.setAttribute('src', '//ad.crwdcntrl.net/5/c=16235/pe=y/var=tncms_siteaud'); var aHead = document.getElementsByTagName("head"); if (aHead && aHead[0]) { if (TNCMS && TNCMS.Tracking) { var oTracker = TNCMS.Tracking.createBucket({ 'app': 'tncms-dmp', 'metric': 'audience-extraction', 'data': { name: 'client', value: 16235 } }); oTracker.addEvent(new Date().getTime()); } aHead[0].appendChild(oScript); } } })(function(aAudiences) { window.TNCMS.Access.push(function() { TNCMS.Access.setAudiences(aAudiences); });}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.394adeeb6831ca20cb80bc3489a2f345.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.status.828de94349981272665c0fb0107f3e49.js"></script>
<script>/*<![CDATA[*/ __tnt.subscription.access.status.check(function(data){
    /* time to consume tracker - time in seconds: 137 */
    setTimeout(function(){
        __tnt.log("Access - validated user view");
        _cc16235.add('act', read_article);_cc16235.bcp();
    }, 68500);
}); /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["local"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.newyork1.vip.townnews.com\/dailyadvance.com\/content\/tncms\/live\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.js?_dc=1600789514",
        pageCurl:"https:\/\/bloximages.newyork1.vip.townnews.com\/dailyadvance.com\/content\/tncms\/live\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.js?_dc=1600789514",
        parallax:"https:\/\/bloximages.newyork1.vip.townnews.com\/dailyadvance.com\/content\/tncms\/live\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.js?_dc=1600789514",
        paw:"https:\/\/bloximages.newyork1.vip.townnews.com\/dailyadvance.com\/content\/tncms\/live\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.js?_dc=1600789514",
        pencil:"https:\/\/bloximages.newyork1.vip.townnews.com\/dailyadvance.com\/content\/tncms\/live\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.js?_dc=1600789514",
        reveal:"https:\/\/bloximages.newyork1.vip.townnews.com\/dailyadvance.com\/content\/tncms\/live\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.js?_dc=1600789514",
        stickyAnchor:"https:\/\/bloximages.newyork1.vip.townnews.com\/dailyadvance.com\/content\/tncms\/live\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/sticky-anchor.js?_dc=1600789514",
        video:"https:\/\/bloximages.newyork1.vip.townnews.com\/dailyadvance.com\/content\/tncms\/live\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.js?_dc=1600789514",
        wallpaper:"https:\/\/bloximages.newyork1.vip.townnews.com\/dailyadvance.com\/content\/tncms\/live\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.js?_dc=1600789514"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/21850262885/dailyadvance.com/weatherwidget';
            
                gptAdSlots['ad-826858'] = googletag.defineSlot(adUnit, [400,100], 'ad-826858').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/21850262885/dailyadvance.com/news/local';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [320,50]).addSize([992, 0], [728,90]).addSize([1200, 0], [728,90]).build();
                gptAdSlots['ad-777761'] = googletag.defineSlot(adUnit, [[320,50],[728,90]], 'ad-777761').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-777761'].setTargeting('pos', ['leaderboard-top']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/21850262885/dailyadvance.com/news/local';
            
                gptAdSlots['ad-818268'] = googletag.defineSlot(adUnit, [300,250], 'ad-818268').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-818268'].setTargeting('pos', ['MediumRectangle-Top']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/tntslider.da69ed76c68b04e70d7bf500b28979da.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/21850262885/dailyadvance.com/news/local';
            
                gptAdSlots['ad-827672'] = googletag.defineSlot(adUnit, [300,600], 'ad-827672').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-827672'].setTargeting('pos', ['HalfPage']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/21850262885/dailyadvance.com/news/local';
            
                gptAdSlots['ad-827689'] = googletag.defineSlot(adUnit, [300,250], 'ad-827689').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-827689'].setTargeting('pos', ['MediumRectangle-Middle']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/21850262885/dailyadvance.com/news/local';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [468,60]).addSize([992, 0], [728,90]).addSize([1200, 0], [728,90]).build();
                gptAdSlots['ad-777763'] = googletag.defineSlot(adUnit, [[320,50],[468,60],[728,90]], 'ad-777763').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-777763'].setTargeting('pos', ['Leaderboard-Bottom']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/21850262885/dailyadvance.com/stickyanchor';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320,50], [320,100]]).addSize([768, 0], [[1170,100], [728,90]]).addSize([992, 0], [[1170,100], [728,90]]).addSize([1200, 0], [[1170,100], [728,90]]).build();
                gptAdSlots['ad-1039458'] = googletag.defineSlot(adUnit, [[320,50],[320,100],[1170,100],[728,90]], 'ad-1039458').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Royal Farms plans to build first NC store in Grandy | Local News | dailyadvance.com</title>
<meta name="m:id" content="75cb564c-8988-5311-a1c0-053adacfebef">

            
    <style>body { background-color: #ffffff; color: #000; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #1c3866; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #1c3866; } .fixed-nav #main-navigation { background-color: #1c3866 !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer-container, #site-footer { background-color: #ffffff; color: #000; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #FFF; } .navbar-toggle .icon-bar { background-color: #FFF !important; } .navbar-toggle .sr-only-show { color: #FFF !important; } #site-top-nav .list-inline>li>a { color: #000; } .asset .asset-body p, .asset #asset-content p { color: #000; } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-bottom-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #FFF; } }#site-copyright a, #site-footer a { color: #000; }.search-redesign .top-breakout > .row { max-width: 1200px; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #1c3866; }#site-header-container{ border-bottom: 3px solid #1c3866; }#site-footer-container{ border-top: 3px solid #1c3866; } .tnt-bg-accent { background-color: #1c3866; } a .tnt-caret-down { color: #1c3866; } .block-title .block-title-inner { border-color: #1c3866; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #1c3866; } .form-control:focus { border-bottom-color: #1c3866; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ #collapse-subscription > a:nth-child(2) a.list-group-item { display: none; } </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <div id="fb-root"></div> <script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.3"></script> <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.dailyadvance.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/10c5c2aa-f9cd-11e9-92bb-3ffb429a789a.png?crop=38%2C38%2C38%2C0&resize=180%2C180&order=crop%2Cresize" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Royal Farms plans to build first NC store in Grandy | Local News | dailyadvance.com" href="http://www.dailyadvance.com/search/?f=rss&amp;t=article&amp;c=news/local&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.dailyadvance.com/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.3aa64d478db9cdd63e9d4b159e0c9334.js"></script>
              


  

<script>
   window.oncontextmenu = function () {
       return false;
    }
</script>

<script data-ad-client="ca-pub-2818127206321507" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

  




<script>
    document.addEventListener('DOMContentLoaded', function() {
        var x = document.querySelectorAll(".not-logged-in a.btn.btn-link.btn-sm.user-control-link"),
            i;
        for (i = 0; i < x.length; i++) {
          x[i].innerHTML = 'Subscribe';
        }
    });
</script>


        </head>
        <body class="app-editorial grid-mobile-pattern blox-asset uuid-75cb564c-8988-5311-a1c0-053adacfebef  section-news section-local type-article infinity-disabled" data-path="/news/local">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.dailyadvance.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.60.5&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=mobile_pattern&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews%2Flocal&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.asset.author=Paul+Nielsen%0AStaff+Writer&amp;tncms.asset.start_hour=16&amp;tncms.asset.id=75cb564c-8988-5311-a1c0-053adacfebef&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fnews%2Flocal%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=296&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PLNLF2D&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.60.5&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=mobile_pattern&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews%2Flocal&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.asset.author=Paul+Nielsen%0AStaff+Writer&amp;tncms.asset.start_hour=16&amp;tncms.asset.id=75cb564c-8988-5311-a1c0-053adacfebef&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fnews%2Flocal%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=296&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a>
        
        
        
        <div id="service-promo-modal" data-endpoint="https://www.dailyadvance.com/tncms/subscription/services/?promoCode="  data-software-version="1.37.0">
        <div class="modal fade">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
                            <span aria-hidden="true">&times;</span>
                        </button><h3 id="access-modal-title"></h3>
                    </div>

                    <div class="modal-body">
                        <div class="access-methods-list">
                            <template class="template promo-error-template">
                                <div class="promo-error alert alert-warning">
    <p><strong>Sorry</strong>, an error occurred.</p>
</div></template><template class="template-promo-service hide">
                                <div class="promotion-service subscription-service panel panel-default">
                                    <h3 class="method-header"></h3>
                                    <div class="method-description"></div>
                                    <div class="method-footer">
                                        <a data-subscription-service="" class="method-link btn btn-primary btn-lg">Get Started</a>
                                    </div>
                                </div>
                            </template>

                            <div class="access-login text-center"><div id="access-modal-description"></div>
                                <div class="not-logged-in">
                                    <div id="access-modal-user-links">
    <a class="btn btn-primary btn-lg" href="https://www.dailyadvance.com/users/login/?referer_url=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html">Log In</a>
    <a id="access-registration" class="btn btn-primary btn-lg hidden" href="https://apg01.newzware.com/ss70v2/enc/common/template.jsp?init=start&initEdition=EDA&return=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html">Sign Up</a></div>
                                </div>
                            </div>
                            <div class="clearfix"></div>
                            
                            <h2 class="promo-loading text-center font-larger" style="display:none;"><span class="fas tnt-spinner tnt-spin"></span></h2><div id="access-methods" class="output" data-referer="https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html"></div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                </div>
            </div>
        </div>
    </div><script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.dailyadvance.com/tncms/admin/editorial-asset/?edit=75cb564c-8988-5311-a1c0-053adacfebef"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs" aria-label="Right Main Menu" aria-expanded="false" tabindex="-1">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-777873" class="tncms-block hidden-md hidden-lg"><div id="user-controls-777873" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://apg01.newzware.com/ss70v2/enc/common/template.jsp?init=start&initEdition=EDA&return=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.dailyadvance.com/users/login/?referer_url=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.dailyadvance.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-777873').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.dailyadvance.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.dailyadvance.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.dailyadvance.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-777873').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.dailyadvance.com/users/logout/" id="user-logout-form-777873"><input type="hidden" name="referer_url" value="https://www.dailyadvance.com/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-829304" class="tncms-block padding-top"><div id="weather-829304" class="weather-current size-medium pull-left">
    <ul class="list-unstyled">
        <li class="current-conditions ">
            <a href="/weather/?weather_zip=27909" class="dropdown-toggle"  aria-label="Weather">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">39&deg;</span>
                    
                        <span class="cond">Clear </span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/local/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/business/"  class="nav-link tnt-section-business">Business</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/crime/"  class="nav-link tnt-section-crime">Crime</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/state/"  class="nav-link tnt-section-state">State</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/national/"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/world/"  class="nav-link tnt-section-world">World</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters/"  class="nav-link tnt-section-letters">Letters</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editorial_columnists/"  class="nav-link tnt-section-editorial-columnists">Editorial Columnists</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/letter_editor"  class="nav-link tnt-section-submit-your-letter">Submit Your Letter</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/local/"  class="nav-link tnt-section-local-sports">Local Sports</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/high_schools/"  class="nav-link tnt-section-high-schools">High Schools</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/college/"  class="nav-link tnt-section-college">College</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/professional/"  class="nav-link tnt-section-professional">Professional</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/features/"  class="nav-link tnt-section-features">Features</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/"  class="nav-link tnt-section-feature-stories">Feature Stories</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/entertainment/"  class="nav-link tnt-section-entertainment">Entertainment</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/virtual_graduations/"  class="nav-link tnt-section-graduate-profiles">Graduate Profiles</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/obits/"  class="nav-link tnt-section-obits">Obits</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/multimedia/"  class="nav-link tnt-section-multimedia">Multimedia</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/multimedia/photo_galleries/"  class="nav-link tnt-section-photo-galleries">Photo Galleries</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/multimedia/video_gallery/"  class="nav-link tnt-section-videos">Videos</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/local-events/"  class="nav-link tnt-section-local-events">Local Events</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="https://easternnorthcarolina.jobs/"  target="_blank" rel="noopener" class="nav-link tnt-section-jobs">Jobs</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-9" data-target="#mobile-nav-right_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.dailyadvance.com/classifieds/community/announcements/legal/"  target="_blank" rel="noopener" class="nav-link tnt-section-public-notices">Public Notices</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://issuu.com/cookecommunicationsnc/docs/advanceservicedirectory?fr=sMWRiOTMxMzUzNTU"  target="_blank" rel="noopener" class="nav-link tnt-section-service-directory">Service Directory</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/eedition/"  class="nav-link tnt-section-e-edition">e-Edition</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-11" data-target="#mobile-nav-right_menu-child-11">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true"   class="nav-link tnt-section-our-sites">Our Sites</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-11" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.reflector.com"  target="_blank" rel="noopener" class="nav-link tnt-section-the-daily-reflector">The Daily Reflector</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.rockymounttelegram.com"  target="_blank" rel="noopener" class="nav-link tnt-section-rocky-mount-telegram">Rocky Mount Telegram</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/bertie/"  class="nav-link tnt-section-bertie-ledger-advance">Bertie Ledger-Advance</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/chowan/"  class="nav-link tnt-section-chowan-herald">Chowan Herald</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/perquimans/"  class="nav-link tnt-section-the-perquimans-weekly">The Perquimans Weekly</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.reflector.com/enterprise/"  target="_blank" rel="noopener" class="nav-link tnt-section-the-enterprise">The Enterprise</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-12" data-target="#mobile-nav-right_menu-child-12">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true"   class="nav-link tnt-section-extras">Extras</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-12" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://dailyadvance.secondstreetapp.com/15000-Free-Rent-or-Mortgage"  target="_blank" rel="noopener" class="nav-link tnt-section-free-rent-or-mortgage-for-a-year">Free Rent or Mortgage For A Year</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://dailyadvance.secondstreetapp.com/ECU-Football-Ticket-Giveaway"  target="_blank" rel="noopener" class="nav-link tnt-section-ecu-football-ticket-giveaway">ECU Football Ticket Giveaway</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://dailyadvance.secondstreetapp.com/Best-of-the-Albemarle-2021/"  target="_blank" rel="noopener" class="nav-link tnt-section-best-of-the-albemarle">Best of the Albemarle</a>
                                </li></ul></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-777869" class="tncms-block hidden-md hidden-lg"><ul id="site-search-777869-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown" aria-label="Search">
                <span class="fas tnt-search"></span>
            </a>
            <ul class="dropdown-menu">
                <li><form id="site-search-777869" aria-labelledby="site-search-button-777869" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal ">
        <input id="site-search-777869-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-777869-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-777869" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-777869-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-777869').submit();
        return false;
    });

    $('#site-search-777869').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-777869 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-777869 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-777869-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list" ></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-777872" class="tncms-block padding-top"><div id="user-controls-777872" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://apg01.newzware.com/ss70v2/enc/common/template.jsp?init=start&initEdition=EDA&return=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.dailyadvance.com/users/login/?referer_url=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.dailyadvance.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-777872').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.dailyadvance.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.dailyadvance.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.dailyadvance.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-777872').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.dailyadvance.com/users/logout/" id="user-logout-form-777872"><input type="hidden" name="referer_url" value="https://www.dailyadvance.com/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-777870" class="tncms-block"><div class="follow-links-777870 pull-right">
    
    <section id="block-777870" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/thedailyadvance" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/dailyadvance" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.dailyadvance.com",
  "sameAs" : ["https://www.facebook.com/thedailyadvance","https://twitter.com/dailyadvance"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-828135" class="tncms-block"><a href="/"><img src="/content/tncms/custom/image/841bbb52-f9c7-11e9-938c-43bd7d52d546.png"></a></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-777874" class="tncms-block"><div id="weather-777874" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=27909" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" aria-label="Weather">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">39&deg;</span>
                    
                        <span class="cond">Clear <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather Zip Code" value="27909">
                                <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a id="weather_zip_toggle_777874" class="pull-right zip-update-link" aria-label="weather_zip_toggle"><span class="fas tnt-cog"></span></a><h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Elizabeth City, NC
                                
                                <small>(27909)</small>
                            </h4><h5>Today</h5>
                                <p>Mostly clear. Low 26F. Winds NW at 10 to 15 mph..
                                </p>
                                <h5>Tonight</h5>
                                <p>Mostly clear. Low 26F. Winds NW at 10 to 15 mph.</p>
                                <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: January 10, 2022 @ 6:30 pm</small></p></div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center">
                        <a href="/weather/?weather_zip=27909"><i class="fas tnt-caret-right"></i> Full Forecast</a>
                    </li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-826858" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-826858" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-826858');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button  type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right" aria-label="Right Main Menu" aria-expanded="false" >
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>

                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-777865" class="tncms-block"><div id="site-logo-777865" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/6f56dd40-86f5-11e9-ad37-17c9f5916e6c.png?resize=200%2C49" 
            srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/6f56dd40-86f5-11e9-ad37-17c9f5916e6c.png?resize=150%2C37 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/6f56dd40-86f5-11e9-ad37-17c9f5916e6c.png?resize=200%2C49 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/6f56dd40-86f5-11e9-ad37-17c9f5916e6c.png?resize=225%2C55 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/6f56dd40-86f5-11e9-ad37-17c9f5916e6c.png?resize=300%2C73 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/6f56dd40-86f5-11e9-ad37-17c9f5916e6c.png 400w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="320"
            height="78"
            alt="site-logo"
            ></a>
        </div></div></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-777868" class="tncms-block"><ul id="site-search-777868-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown" aria-label="Search">
                <span class="fas tnt-search"></span>
            </a>
            <ul class="dropdown-menu">
                <li><form id="site-search-777868" aria-labelledby="site-search-button-777868" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal ">
        <input id="site-search-777868-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-777868-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-777868" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-777868-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-777868').submit();
        return false;
    });

    $('#site-search-777868').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-777868 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-777868 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-777868-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-local-news"  href="/news/local/"  tabindex="0">
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-business"  href="/news/business/"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-crime"  href="/news/crime/"  tabindex="0">
                    <span class="nav-label">Crime</span>
                </a></li><li>
                <a class="nav-link   tnt-section-state"  href="/news/state/"  tabindex="0">
                    <span class="nav-label">State</span>
                </a></li><li>
                <a class="nav-link   tnt-section-national"  href="/news/national/"  tabindex="0">
                    <span class="nav-label">National</span>
                </a></li><li>
                <a class="nav-link   tnt-section-world"  href="/news/world/"  tabindex="0">
                    <span class="nav-label">World</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion/"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-editorials"  href="/opinion/editorials/"  tabindex="0">
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link   tnt-section-letters"  href="/opinion/letters/"  tabindex="0">
                    <span class="nav-label">Letters</span>
                </a></li><li>
                <a class="nav-link   tnt-section-editorial-columnists"  href="/opinion/editorial_columnists/"  tabindex="0">
                    <span class="nav-label">Editorial Columnists</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-your-letter"  href="/site/forms/online_services/letter_editor"  tabindex="0">
                    <span class="nav-label">Submit Your Letter</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-local-sports"  href="/sports/local/"  tabindex="0">
                    <span class="nav-label">Local Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-high-schools"  href="/sports/high_schools/"  tabindex="0">
                    <span class="nav-label">High Schools</span>
                </a></li><li>
                <a class="nav-link   tnt-section-college"  href="/sports/college/"  tabindex="0">
                    <span class="nav-label">College</span>
                </a></li><li>
                <a class="nav-link   tnt-section-professional"  href="/sports/professional/"  tabindex="0">
                    <span class="nav-label">Professional</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-features"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/features/"  tabindex="0">
                    <span class="nav-label">Features</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-feature-stories"  href="/features/"  tabindex="0">
                    <span class="nav-label">Feature Stories</span>
                </a></li><li>
                <a class="nav-link   tnt-section-entertainment"  href="/features/entertainment/"  tabindex="0">
                    <span class="nav-label">Entertainment</span>
                </a></li><li>
                <a class="nav-link   tnt-section-graduate-profiles"  href="/virtual_graduations/"  tabindex="0">
                    <span class="nav-label">Graduate Profiles</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-obits"  href="/obits/"  tabindex="0">
                    <span class="nav-label">Obits</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-multimedia"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/multimedia/"  tabindex="0">
                    <span class="nav-label">Multimedia</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-photo-galleries"  href="/multimedia/photo_galleries/"  tabindex="0">
                    <span class="nav-label">Photo Galleries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-videos"  href="/multimedia/video_gallery/"  tabindex="0">
                    <span class="nav-label">Videos</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-local-events"  href="/local-events/"  tabindex="0">
                    <span class="nav-label">Local Events</span>
                </a></li><li>
                <a class="nav-link   tnt-section-jobs"  href="https://easternnorthcarolina.jobs/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Jobs</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-public-notices"  href="https://www.dailyadvance.com/classifieds/community/announcements/legal/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Public Notices</span>
                </a></li><li>
                <a class="nav-link   tnt-section-service-directory"  href="https://issuu.com/cookecommunicationsnc/docs/advanceservicedirectory?fr=sMWRiOTMxMzUzNTU"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Service Directory</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition/"  tabindex="0">
                    <span class="nav-label">e-Edition</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-our-sites"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0">
                    <span class="nav-label">Our Sites</span>
                </a><ul id="main-nav_menu-child-11" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-the-daily-reflector"  href="https://www.reflector.com"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">The Daily Reflector</span>
                </a></li><li>
                <a class="nav-link   tnt-section-rocky-mount-telegram"  href="https://www.rockymounttelegram.com"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Rocky Mount Telegram</span>
                </a></li><li>
                <a class="nav-link   tnt-section-bertie-ledger-advance"  href="/bertie/"  tabindex="0">
                    <span class="nav-label">Bertie Ledger-Advance</span>
                </a></li><li>
                <a class="nav-link   tnt-section-chowan-herald"  href="/chowan/"  tabindex="0">
                    <span class="nav-label">Chowan Herald</span>
                </a></li><li>
                <a class="nav-link   tnt-section-the-perquimans-weekly"  href="/perquimans/"  tabindex="0">
                    <span class="nav-label">The Perquimans Weekly</span>
                </a></li><li>
                <a class="nav-link   tnt-section-the-enterprise"  href="https://www.reflector.com/enterprise/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">The Enterprise</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-extras"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0">
                    <span class="nav-label">Extras</span>
                </a><ul id="main-nav_menu-child-12" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-free-rent-or-mortgage-for-a-year"  href="https://dailyadvance.secondstreetapp.com/15000-Free-Rent-or-Mortgage"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Free Rent or Mortgage For A Year</span>
                </a></li><li>
                <a class="nav-link   tnt-section-ecu-football-ticket-giveaway"  href="https://dailyadvance.secondstreetapp.com/ECU-Football-Ticket-Giveaway"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">ECU Football Ticket Giveaway</span>
                </a></li><li>
                <a class="nav-link   tnt-section-best-of-the-albemarle"  href="https://dailyadvance.secondstreetapp.com/Best-of-the-Albemarle-2021/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Best of the Albemarle</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
        <div class="visible-xs pull-right article-share-nav" style="background-color: #1c3866">
            <span>Share This <i class="fas tnt-arrow-right"></i></span>
            <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Royal%20Farms%20plans%20to%20build%20first%20NC%20store%20in%20Grandy&url=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.dailyadvance.com/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.dailyadvance.com/tncms/asset/editorial/75cb564c-8988-5311-a1c0-053adacfebef" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bdailyadvance.com%5D%20Royal%20Farms%20plans%20to%20build%20first%20NC%20store%20in%20Grandy&body=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
        </div>
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-780067" class="tncms-block w-alert"></div><div id="tncms-block-777859" class="tncms-block"></div><div id="tncms-block-777761" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-777761" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-777761');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-955781" class="tncms-block visible-lg visible-md visible-sm center-image"><section id="block-955781" class="block emphasis-h3   " ><div class="block"><a href="https://www.pediment.com/products/albemarle-memories-history-book-vol-1?utm_medium=banner&utm_source=adams_publishing_group&utm_campaign=albemarle_region_north_carolina_memories" rel="nofollow noopener" target="_blank" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/3579c000-6cb3-11ec-aa9e-dbcc2e6ac16c.jpg?resize=150%2C13 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/3579c000-6cb3-11ec-aa9e-dbcc2e6ac16c.jpg?resize=200%2C17 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/3579c000-6cb3-11ec-aa9e-dbcc2e6ac16c.jpg?resize=225%2C19 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/3579c000-6cb3-11ec-aa9e-dbcc2e6ac16c.jpg?resize=300%2C26 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/3579c000-6cb3-11ec-aa9e-dbcc2e6ac16c.jpg?resize=400%2C34 400w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/3579c000-6cb3-11ec-aa9e-dbcc2e6ac16c.jpg?resize=540%2C46 540w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/3579c000-6cb3-11ec-aa9e-dbcc2e6ac16c.jpg?resize=640%2C55 640w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/3579c000-6cb3-11ec-aa9e-dbcc2e6ac16c.jpg?resize=750%2C64 750w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/3579c000-6cb3-11ec-aa9e-dbcc2e6ac16c.jpg?resize=990%2C85 990w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/3579c000-6cb3-11ec-aa9e-dbcc2e6ac16c.jpg?resize=1035%2C88 1035w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/3579c000-6cb3-11ec-aa9e-dbcc2e6ac16c.jpg 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="1170"
                height="100"
                alt=""
                aria-hidden="true"></a></div></section></div><div id="tncms-block-924718" class="tncms-block visible-xs center-image"><section id="block-924718" class="block emphasis-h3   " ><div class="block"><a href="https://www.pediment.com/products/albemarle-memories-history-book-vol-1?utm_medium=banner&utm_source=adams_publishing_group&utm_campaign=albemarle_region_north_carolina_memories" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/52dba212-6cb3-11ec-b21e-af2ae1944595.jpg?resize=150%2C23 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/52dba212-6cb3-11ec-b21e-af2ae1944595.jpg?resize=200%2C31 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/52dba212-6cb3-11ec-b21e-af2ae1944595.jpg?resize=225%2C35 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/52dba212-6cb3-11ec-b21e-af2ae1944595.jpg?resize=300%2C47 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/custom/image/52dba212-6cb3-11ec-b21e-af2ae1944595.jpg 400w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="320"
                height="50"
                alt=""
                aria-hidden="true"></a></div></section></div></div></div>
        </div><div id="modal-image-8c7c555a-c011-5c73-8bfe-811782057ed0" class="modal fullscreen in modal-image image-default modal-8c7c555a-c011-5c73-8bfe-811782057ed0" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=400%2C208"
                    srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=150%2C78 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=200%2C104 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=225%2C117 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=300%2C156 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=400%2C208 400w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=540%2C281 540w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=640%2C333 640w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=750%2C390 750w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=913%2C475 990w"
                    sizes="100vw"
                    
                    width="913"
                    height="475"
                    alt="royal farms schematicls"
                    class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-8c7c555a-c011-5c73-8bfe-811782057ed0" data-target=".caption-inner-modal-image-8c7c555a-c011-5c73-8bfe-811782057ed0">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-8c7c555a-c011-5c73-8bfe-811782057ed0 collapse in"><div class="caption-text"><div class="subscriber-preview"><p>This artist’s rendering shows what the planned Royal Farms store in Grandy will look once it’s built. The Maryland-based convenience store operator plans to open a 5,300-square-foot store at the corner of Caratoke Highway and Walnut Island Boulevard. No timetable for the store’s construction has been released.</p></div></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span id="author-6c19a5ce-fbdd-11e9-aa88-1f7a2478ce41-asset-8c7c555a-c011-5c73-8bfe-811782057ed0" class="tnt-byline asset-byline"  ><a href="https://www.dailyadvance.com/users/profile/cday">Graphic courtesy Currituck County</a></span>
                </li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.dailyadvance.com%2Froyal-farms-schematicls%2Fimage_8c7c555a-c011-5c73-8bfe-811782057ed0.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/royal-farms-schematicls/image_8c7c555a-c011-5c73-8bfe-811782057ed0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c7c555a-c011-5c73-8bfe-811782057ed0"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=royal%20farms%20schematicls&url=https%3A%2F%2Fwww.dailyadvance.com%2Froyal-farms-schematicls%2Fimage_8c7c555a-c011-5c73-8bfe-811782057ed0.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/royal-farms-schematicls/image_8c7c555a-c011-5c73-8bfe-811782057ed0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c7c555a-c011-5c73-8bfe-811782057ed0"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.dailyadvance.com/royal-farms-schematicls/image_8c7c555a-c011-5c73-8bfe-811782057ed0.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/royal-farms-schematicls/image_8c7c555a-c011-5c73-8bfe-811782057ed0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c7c555a-c011-5c73-8bfe-811782057ed0"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.dailyadvance.com/tncms/asset/editorial/8c7c555a-c011-5c73-8bfe-811782057ed0" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"8c7c555a-c011-5c73-8bfe-811782057ed0"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bdailyadvance.com%5D%20royal%20farms%20schematicls&body=https%3A%2F%2Fwww.dailyadvance.com%2Froyal-farms-schematicls%2Fimage_8c7c555a-c011-5c73-8bfe-811782057ed0.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"8c7c555a-c011-5c73-8bfe-811782057ed0"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/royal-farms-schematicls/image_8c7c555a-c011-5c73-8bfe-811782057ed0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c7c555a-c011-5c73-8bfe-811782057ed0"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-8c7c555a-c011-5c73-8bfe-811782057ed0-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="8c7c555a-c011-5c73-8bfe-811782057ed0" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="8c7c555a-c011-5c73-8bfe-811782057ed0" class="save-list-8c7c555a-c011-5c73-8bfe-811782057ed0-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="8c7c555a-c011-5c73-8bfe-811782057ed0" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-8c7c555a-c011-5c73-8bfe-811782057ed0 img { max-height: 475px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-75cb564c-8988-5311-a1c0-053adacfebef" class="asset article-default"  data-url="https://www.dailyadvance.com/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="CURRITUCK — Royal Farm’s world famous fried chicken is coming to Currituck. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?crop=905%2C475%2C4%2C0&resize=905%2C475&order=crop%2Cresize">
            <meta itemprop="width" content="905">
            <meta itemprop="height" content="475">
        </div>
        <meta itemprop="name" content="dailyadvance.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.dailyadvance.com/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html" />
    <style>
                .asset-paging .direction {
                    color: #1c3866;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.dailyadvance.com\/tncms\/search\/mlt\/?origin=75cb564c-8988-5311-a1c0-053adacfebef&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"75cb564c-8988-5311-a1c0-053adacfebef","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-75cb564c-8988-5311-a1c0-053adacfebef" class="asset-paging">
                <div id="paging-prev-75cb564c-8988-5311-a1c0-053adacfebef" class="paging-link prev offset"></div>
                <div id="paging-next-75cb564c-8988-5311-a1c0-053adacfebef" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper no-flags">
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            Royal Farms plans to build first NC store in Grandy
        </span>
    </h1>
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">By Paul Nielsen
Staff Writer</span></li>
        
        
            <li class="visible-print">
        <time datetime="2022-01-10T16:55:00-05:00" class="tnt-date asset-date text-muted">
            Jan 10, 2022
        </time></li>
            <li class="hidden-print">
        <time datetime="2022-01-10T16:55:00-05:00" class="tnt-date asset-date text-muted">2 hrs ago</time></li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-01-10T16:55:00-05:00">
    <meta itemprop="datePublished" content="2022-01-10T16:55:00-05:00">
    <meta itemprop="dateModified" content="2022-01-10T16:55:00-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Royal%20Farms%20plans%20to%20build%20first%20NC%20store%20in%20Grandy&url=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.dailyadvance.com/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.dailyadvance.com/tncms/asset/editorial/75cb564c-8988-5311-a1c0-053adacfebef" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bdailyadvance.com%5D%20Royal%20Farms%20plans%20to%20build%20first%20NC%20store%20in%20Grandy&body=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-8c7c555a-c011-5c73-8bfe-811782057ed0" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-8c7c555a-c011-5c73-8bfe-811782057ed0" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="913">
            <meta itemprop="height" content="475">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg">
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=400%2C208"
                    srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=150%2C78 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=200%2C104 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=225%2C117 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=300%2C156 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=400%2C208 400w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=540%2C281 540w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=640%2C333 640w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=750%2C390 750w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c7/8c7c555a-c011-5c73-8bfe-811782057ed0/61dcb2f53c8d7.image.jpg?resize=913%2C475 990w"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                    
                    width="913"
                    height="475"
                    alt="royal farms schematicls"
                    class="img-responsive full tnt-restrict-img-8c7c555a-c011-5c73-8bfe-811782057ed0 default" />
            </div><style>
                .tnt-restrict-img-8c7c555a-c011-5c73-8bfe-811782057ed0 {
                    max-width: 913px;
                }
            </style>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p>This artist’s rendering shows what the planned Royal Farms store in Grandy will look once it’s built. The Maryland-based convenience store operator plans to open a 5,300-square-foot store at the corner of Caratoke Highway and Walnut Island Boulevard. No timetable for the store’s construction has been released.</p>
                                </span>
                            
                        
                            
                                <span class="credit">
                                    <span id="author-6c19a5ce-fbdd-11e9-aa88-1f7a2478ce41-asset-8c7c555a-c011-5c73-8bfe-811782057ed0" class="tnt-byline asset-byline"  ><a href="https://www.dailyadvance.com/users/profile/cday">Graphic courtesy Currituck County</a></span>
                
                                </span>
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="75cb564c-8988-5311-a1c0-053adacfebef">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                            
                            <div id="share-left-affix" class="share-container content-left hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Royal%20Farms%20plans%20to%20build%20first%20NC%20store%20in%20Grandy&url=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.dailyadvance.com/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.dailyadvance.com/tncms/asset/editorial/75cb564c-8988-5311-a1c0-053adacfebef" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bdailyadvance.com%5D%20Royal%20Farms%20plans%20to%20build%20first%20NC%20store%20in%20Grandy&body=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-75cb564c-8988-5311-a1c0-053adacfebef-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="75cb564c-8988-5311-a1c0-053adacfebef" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="75cb564c-8988-5311-a1c0-053adacfebef" class="save-list-75cb564c-8988-5311-a1c0-053adacfebef-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="75cb564c-8988-5311-a1c0-053adacfebef" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                            <script>
                                $(window).load(function() {
                                    window.setTimeout(affixShare, 2000);
                                    function affixShare() {
                                        var sHeight = $('#share-left-affix').outerHeight(true);
                                        var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                        var sTop = $('#share-left-affix').offset().top - 50;
                                        var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + cHeight - 50);
                                        if(cHeight > sHeight) {
                                            $('#share-left-affix').affix({
                                                offset: { top: sTop, bottom: sBottom }
                                            });
                                        }
                                    }
                                });
                                $(window).resize(function() {
                                    var sHeight = $('#share-left-affix').outerHeight(true);
                                    var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                    var sTop = $('#share-left-affix').offset().top - 50;
                                    var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + $('#share-left-affix').parent().outerHeight(true) - 50);
                                    if(cHeight > sHeight) {
                                        $('#share-left-affix').data('bs.affix').options.offset.top = sTop;
                                        $('#share-left-affix').data('bs.affix').options.offset.bottom = sBottom;
                                    }
                                });
                            </script>
                            
                        
                        <div class="asset-body has-fixed-share" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above visible-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Royal%20Farms%20plans%20to%20build%20first%20NC%20store%20in%20Grandy&url=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.dailyadvance.com/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.dailyadvance.com/tncms/asset/editorial/75cb564c-8988-5311-a1c0-053adacfebef" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bdailyadvance.com%5D%20Royal%20Farms%20plans%20to%20build%20first%20NC%20store%20in%20Grandy&body=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-75cb564c-8988-5311-a1c0-053adacfebef-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="75cb564c-8988-5311-a1c0-053adacfebef" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="75cb564c-8988-5311-a1c0-053adacfebef" class="save-list-75cb564c-8988-5311-a1c0-053adacfebef-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="75cb564c-8988-5311-a1c0-053adacfebef" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p>CURRITUCK — Royal Farm’s world famous fried chicken is coming to Currituck.</p></div><div class="subscriber-preview"><p>Gas and other convenience items, too.</p></div><div class="subscriber-only"><p>The Maryland-based convenience store operator, which bills itself as providing “world famous fresh friend chicken,” has chosen Grandy for its first store location in North Carolina.</p></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>Currituck commissioners last week unanimously approved a rezoning request for the Royal Farms store that will be located at the corner of Caratoke Highway and Walnut Island Boulevard.</p></div><div class="subscriber-only"><p>“Good fried chicken,” Commissioner Owen Etheridge said before the vote.</p></div><div class="subscriber-only"><p>Commissioner Paul Beaumont told representatives for Royal Farms that they picked a good location for their first store in the state. Royal Farms currently operates more than 250 stores in Virginia, Maryland, Pennsylvania and Delaware.</p></div><div class="subscriber-only"><p>“Welcome to North Carolina,” Beaumont said. “If you had to pick a place to start, we deserve to be the first with a Royal Farms. On the Eastern Shore that is a common place to stop, so welcome to our neighborhood.”</p></div><div class="subscriber-only"><p>Part of the new Grandy site is a former 7-Eleven that is now a retail store. Royals Farms has also purchased two vacant wooden lots and a single-family home on the 3.5-acre site, which is near the Hardee’s and Dunkin Donuts.</p></div><div class="subscriber-only"><p>The former 7-Eleven building will be demolished and new gas tanks will be installed since the tanks were removed when 7-Eleven closed. The single-family home will also be demolished and that part of the parcel will be used for the Royal Farms store’s septic system.</p></div><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"><div id="tncms-block-989994" class="tncms-block"><div class="s2nPlayer k-TUeK1OT4" data-type="float"></div><script type="text/javascript" src="//embed.sendtonews.com/player3/embedcode.js?fk=TUeK1OT4&amp;cid=10547&amp;offsetx=0&amp;offsety=100&amp;floatwidth=400&amp;floatposition=bottom-left" data-type="s2nScript"></script><p><br></p></div></div><div class="subscriber-only"><p>The convenience store will be almost 5,300 square feet and will feature four gas islands with a total of eight pumps. The building will sit in the middle of the parcel with the gas pumps closer to Caratoke Highway.</p></div><div class="subscriber-only"><p>No timetable for the store’s construction has been released but once complete, the store will employ between 35 and 40 people and be open 24 hours a day.</p></div><div class="subscriber-only"><p>Attorney Clint Cogburn representing Royal Farms told commissioners that the company is a chain of “high-end” convenience stores similar to Wawa and Sheetz. He also noted that the 3.5-acre site is larger than most Royal Farms locations.</p></div><div class="subscriber-only"><p>“(Royal Farms) is very excited for this site,” Cogburn said. “They are looking to expand into North Carolina and develop a number of sites in the state. This is the launching point for what they see will be a successful venture in the state of North Carolina.’’</p></div><div class="subscriber-only"><p>The current entrance and exit at the former 7-Eleven on Caratoke Highway will be moved father south and away from the stoplight at Walnut Island Boulevard. There will also be an entrance and exit on Walnut Island Boulevard.</p></div><div class="subscriber-only"><p>“Since they have acquired those other two wooded sites, they are able to move the (Caratoke) entrance further south,” said county Developmental Services Director Kevin Kemp.</p></div><div class="subscriber-only"><p>Commissioner Selina Jarvis asked about the possibility of only allowing customers to enter from Caratoke Highway but not exit back onto the highway. Customers would have to exit onto Walnut Island Boulevard before getting back on Caratoke.</p></div><div class="subscriber-only"><p>Bill McAnally, an engineer for Royal Farms, said the N.C. Department of Transportation does not require a traffic impact analysis for the site because the number of pumps planned is fewer than what the agency requires for such an analysis. He said a traffic consultant for Royal Farms is in the process of filing the store’s driveway permit with NCDOT.</p></div><div class="subscriber-only"><p>“We will work with the state in order to make sure we have a safe ingress and egress access point along Caratoke Highway,” McAnally said. “They (NCDOT) were satisfied with the distance that driveway is located from the red light. It’s actually an improvement to the current situation. This puts it as far away as you can put it.”</p></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Royal%20Farms%20plans%20to%20build%20first%20NC%20store%20in%20Grandy&url=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.dailyadvance.com/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.dailyadvance.com/tncms/asset/editorial/75cb564c-8988-5311-a1c0-053adacfebef" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Bdailyadvance.com%5D%20Royal%20Farms%20plans%20to%20build%20first%20NC%20store%20in%20Grandy&body=https%3A%2F%2Fwww.dailyadvance.com%2Fnews%2Flocal%2Froyal-farms-plans-to-build-first-nc-store-in-grandy%2Farticle_75cb564c-8988-5311-a1c0-053adacfebef.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"75cb564c-8988-5311-a1c0-053adacfebef"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-75cb564c-8988-5311-a1c0-053adacfebef-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="75cb564c-8988-5311-a1c0-053adacfebef" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="75cb564c-8988-5311-a1c0-053adacfebef" class="save-list-75cb564c-8988-5311-a1c0-053adacfebef-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="75cb564c-8988-5311-a1c0-053adacfebef" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div><div id="taboola-video-outstream"></div><div id="taboola-below-article-thumbnails" class="asset-recommend taboola hidden-print" data-page="article" data-mode="thumbnails-a" data-container="taboola-below-article-thumbnails" data-placement="Below Article Thumbnails"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print"></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-777867" class="tncms-block"><section id="block-777867" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-777867 ">
        <div class="block-title-inner">
            <h3>
                
                Latest e-Edition
                
            </h3>
        </div>
    </div></div>
    
        
            <div class="card-panel panel">
                <div class="panel-body">
        <article id="card-summary-9a4e574b-5bd6-5057-a1b9-1c2d114c320a" class="clearfix card summary">
                <div class="card-container">
                        <div class="card-image">
                            <div class="media-preview-9a4e574b-5bd6-5057-a1b9-1c2d114c320a media-preview edition-asset " data-aspect=""><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/eedition/the-daily-advance/edition_9a4e574b-5bd6-5057-a1b9-1c2d114c320a.html" class="tnt-asset-link"  aria-label="The Daily Advance">
                
                
                    <div class="asset-icon"><i class="far tnt-newspaper tnt-fw" title="e-Edition"></i></div>
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="The Daily Advance"
                            class="img-responsive lazyload full default"
                            width="300"
                            height="600"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/eedition/5/81/581771bc-1cd8-522d-9ef2-293d5ec715e0/61d8ea57ca7f2.preview-300.jpg?resize=150%2C300 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/eedition/5/81/581771bc-1cd8-522d-9ef2-293d5ec715e0/61d8ea57ca7f2.preview-300.jpg?resize=200%2C400 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/eedition/5/81/581771bc-1cd8-522d-9ef2-293d5ec715e0/61d8ea57ca7f2.preview-300.jpg?resize=225%2C450 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/eedition/5/81/581771bc-1cd8-522d-9ef2-293d5ec715e0/61d8ea57ca7f2.preview-300.jpg?resize=300%2C600 300w" />
                </a>
                
            </div>
            
        </figure></div>
                        </div>
                    <div class="card-body">
                        <div class="card-headline">
                            <h3 class="tnt-headline ">
        
             <a href="/eedition/the-daily-advance/edition_9a4e574b-5bd6-5057-a1b9-1c2d114c320a.html" class="tnt-asset-link" aria-label="The Daily Advance">
        

        
            The Daily Advance</a></h3>
                        </div>
                            <div class="card-meta">
                                <ul class="list-inline">
                                    
                                    
                                        <li style="padding-bottom:10px;">To view our latest e-Edition click the image on the left.</li>
                                    </ul>
                            </div>
                    </div>
                </div>
                <div class="clearfix"></div>
            </article>
                </div>
            </div>
        
    
    </section></div><div id="tncms-block-818268" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-818268" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-818268');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-780362" class="tncms-block apg">
    <section id="block-780362" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-780362 ">
        <div class="block-title-inner">
            <h3>
                
                Special Editions
                
            </h3>
        </div>
    </div></div>
    <div class="slideshow-carousel-container">
        
            <div class="slideshow-panel panel">
                <div class="panel-body">
        
            <div id="carousel-780362" class="card photo-carousel subscriber-hide letterbox-style-default">
            <template data-id="780362" class="tnt-slider-template" data-auto-slide="true" data-swipe="true" data-arrows="true" data-auto-height="true" data-lazy-load="true"><div class="item photo-cb71eb1e-4563-11eb-85cc-a34eb52760cd tnt-section-niche-pubs">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Royal Farms plans to build first NC store in Grandy","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html","uuid":"75cb564c-8988-5311-a1c0-053adacfebef","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-square">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="https://issuu.com/apg-enc/docs/eda-010722?fr=sOWU5ZjQ0OTAzNTY" target="_blank" rel="noopener">
                                        
        
                <img
                    src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/b7/cb71eb1e-4563-11eb-85cc-a34eb52760cd/61d85a8e0f7bd.preview.png"
                    
                    alt="What 2 Watch"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="250"
                    height="250"
                    data-src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/b7/cb71eb1e-4563-11eb-85cc-a34eb52760cd/61d85a8e0f7bd.preview.png" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-780362 collapse in">
                        <div class="card-headline caption-headline">
                            <h3 class="tnt-headline ">
        
             <a href="https://issuu.com/apg-enc/docs/eda-010722?fr=sOWU5ZjQ0OTAzNTY" class="tnt-asset-link" target="_blank" rel="noopener" aria-label="What 2 Watch">
        

        
            What 2 Watch</a></h3>
                        </div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                            
                        </ul>
                    </div><div class="caption-text">
                            <p></p>
                        </div>
                
            </div>
        </div>
    </div>
                        </div><div class="item photo-17f0384e-58fd-11ec-b402-a317331e10e7 hidden-print tnt-section-niche-pubs">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Royal Farms plans to build first NC store in Grandy","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html","uuid":"75cb564c-8988-5311-a1c0-053adacfebef","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-square">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="https://issuu.com/apg-enc/docs/elm_november_2021_web?fr=sMDA1YjQ0OTAzNTY" >
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Eastern NC Living"
                    class="img-responsive owl-lazy default"
                    width="250"
                    height="250"
                    data-src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/1/7f/17f0384e-58fd-11ec-b402-a317331e10e7/61b21468cb2b8.preview.jpg" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-780362 collapse in">
                        <div class="card-headline caption-headline">
                            <h3 class="tnt-headline ">
        
             <a href="https://issuu.com/apg-enc/docs/elm_november_2021_web?fr=sMDA1YjQ0OTAzNTY" class="tnt-asset-link" aria-label="Eastern NC Living">
        

        
            Eastern NC Living</a></h3>
                        </div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                            
                        </ul>
                    </div><div class="caption-text">
                            <p></p>
                        </div>
                
            </div>
        </div>
    </div>
                        </div><div class="item photo-3d5a6b20-20ba-11ec-8411-a7476348fca0 hidden-print tnt-section-niche-pubs">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Royal Farms plans to build first NC store in Grandy","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html","uuid":"75cb564c-8988-5311-a1c0-053adacfebef","app":"editorial","metric":""}'  data-count="3"  class="photo-container layout-square">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="https://issuu.com/apg-enc/docs/eabm-11182021?fr=sYzkzNjQ0MjYwMjU" target="_blank" rel="noopener">
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Albemarle Magazine Winter 2021"
                    class="img-responsive owl-lazy default"
                    width="250"
                    height="250"
                    data-src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/d5/3d5a6b20-20ba-11ec-8411-a7476348fca0/61a7925f1afa0.preview.jpg" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-780362 collapse in">
                        <div class="card-headline caption-headline">
                            <h3 class="tnt-headline ">
        
             <a href="https://issuu.com/apg-enc/docs/eabm-11182021?fr=sYzkzNjQ0MjYwMjU" class="tnt-asset-link" target="_blank" rel="noopener" aria-label="Albemarle Magazine Winter 2021">
        

        
            Albemarle Magazine Winter 2021</a></h3>
                        </div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                            
                        </ul>
                    </div><div class="caption-text">
                            <p></p>
                        </div>
                
            </div>
        </div>
    </div>
                        </div><div class="item photo-f35fba42-4248-11ec-9be2-fbf537be3d78 hidden-print tnt-section-niche-pubs">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Royal Farms plans to build first NC store in Grandy","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html","uuid":"75cb564c-8988-5311-a1c0-053adacfebef","app":"editorial","metric":""}'  data-count="4"  class="photo-container layout-square">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="https://issuu.com/apg-enc/docs/eda-111021-veteransday?fr=sM2EzYzQzOTYzOTI" target="_blank" rel="noopener">
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Veterans Day 2021"
                    class="img-responsive owl-lazy default"
                    width="250"
                    height="250"
                    data-src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/f/35/f35fba42-4248-11ec-9be2-fbf537be3d78/618bfcf35857f.preview.png" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-780362 collapse in">
                        <div class="card-headline caption-headline">
                            <h3 class="tnt-headline ">
        
             <a href="https://issuu.com/apg-enc/docs/eda-111021-veteransday?fr=sM2EzYzQzOTYzOTI" class="tnt-asset-link" target="_blank" rel="noopener" aria-label="Veterans Day 2021">
        

        
            Veterans Day 2021</a></h3>
                        </div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                            
                        </ul>
                    </div><div class="caption-text">
                            <p></p>
                        </div>
                
            </div>
        </div>
    </div>
                        </div><div class="item photo-e4fb28f2-162d-11ec-9d7f-97ef30481030 hidden-print tnt-section-niche-pubs">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Royal Farms plans to build first NC store in Grandy","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html","uuid":"75cb564c-8988-5311-a1c0-053adacfebef","app":"editorial","metric":""}'  data-count="5"  class="photo-container layout-square">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="https://issuu.com/apg-enc/docs/edass-091121?fr=sMjQ2NTQwNjQzODk" target="_blank" rel="noopener">
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="9/11 20TH Anniversary"
                    class="img-responsive owl-lazy default"
                    width="250"
                    height="250"
                    data-src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/4f/e4fb28f2-162d-11ec-9d7f-97ef30481030/6141fdc0998da.preview.jpg" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-780362 collapse in">
                        <div class="card-headline caption-headline">
                            <h3 class="tnt-headline ">
        
             <a href="https://issuu.com/apg-enc/docs/edass-091121?fr=sMjQ2NTQwNjQzODk" class="tnt-asset-link" target="_blank" rel="noopener" aria-label="9/11 20TH Anniversary">
        

        
            9/11 20TH Anniversary</a></h3>
                        </div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                            
                        </ul>
                    </div><div class="caption-text">
                            <p></p>
                        </div>
                
            </div>
        </div>
    </div>
                        </div><div class="item photo-e4f343f0-f150-11eb-82ad-d71e04705485 hidden-print tnt-section-niche-pubs">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Royal Farms plans to build first NC store in Grandy","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html","uuid":"75cb564c-8988-5311-a1c0-053adacfebef","app":"editorial","metric":""}'  data-count="6"  class="photo-container layout-square">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="https://issuu.com/apg-enc/docs/bestofalbemarle21?fr=sYTE0NDQwNjQzNzQ" target="_blank" rel="noopener">
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Best of the Albmarle"
                    class="img-responsive owl-lazy default"
                    width="250"
                    height="250"
                    data-src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/4f/e4f343f0-f150-11eb-82ad-d71e04705485/61042504c52dc.preview.jpg" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-780362 collapse in">
                        <div class="card-headline caption-headline">
                            <h3 class="tnt-headline ">
        
             <a href="https://issuu.com/apg-enc/docs/bestofalbemarle21?fr=sYTE0NDQwNjQzNzQ" class="tnt-asset-link" target="_blank" rel="noopener" aria-label="Best of the Albmarle">
        

        
            Best of the Albmarle</a></h3>
                        </div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                            
                        </ul>
                    </div><div class="caption-text">
                            <p></p>
                        </div>
                
            </div>
        </div>
    </div>
                        </div><div class="item photo-3931598e-f151-11eb-9248-232e716b2f08 hidden-print tnt-section-niche-pubs">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Royal Farms plans to build first NC store in Grandy","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html","uuid":"75cb564c-8988-5311-a1c0-053adacfebef","app":"editorial","metric":""}'  data-count="7"  class="photo-container layout-square">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="https://issuu.com/apg-enc/docs/homeandgarden21?fr=sZmQ5MTQwNjQzODk" target="_blank" rel="noopener">
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Home &amp; Garden"
                    class="img-responsive owl-lazy default"
                    width="250"
                    height="250"
                    data-src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/93/3931598e-f151-11eb-9248-232e716b2f08/610425dd7aa1c.preview.jpg" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-780362 collapse in">
                        <div class="card-headline caption-headline">
                            <h3 class="tnt-headline ">
        
             <a href="https://issuu.com/apg-enc/docs/homeandgarden21?fr=sZmQ5MTQwNjQzODk" class="tnt-asset-link" target="_blank" rel="noopener" aria-label="Home &amp; Garden">
        

        
            Home & Garden</a></h3>
                        </div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                            
                        </ul>
                    </div><div class="caption-text">
                            <p></p>
                        </div>
                
            </div>
        </div>
    </div>
                        </div><div class="item photo-bb1843fa-8dd2-11eb-ab4d-eb45bc779313 hidden-print tnt-section-niche-pubs">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Royal Farms plans to build first NC store in Grandy","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html","uuid":"75cb564c-8988-5311-a1c0-053adacfebef","app":"editorial","metric":""}'  data-count="8"  class="photo-container layout-square">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="https://issuu.com/cookecommunicationsnc/docs/progress2021-dailyadvance?fr=sNmJkYzMzODYyMzA" target="_blank" rel="noopener">
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Progress 2021"
                    class="img-responsive owl-lazy default"
                    width="250"
                    height="250"
                    data-src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/b/b1/bb1843fa-8dd2-11eb-ab4d-eb45bc779313/605d393196dab.preview.png" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-780362 collapse in">
                        <div class="card-headline caption-headline">
                            <h3 class="tnt-headline ">
        
             <a href="https://issuu.com/cookecommunicationsnc/docs/progress2021-dailyadvance?fr=sNmJkYzMzODYyMzA" class="tnt-asset-link" target="_blank" rel="noopener" aria-label="Progress 2021">
        

        
            Progress 2021</a></h3>
                        </div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                            
                        </ul>
                    </div><div class="caption-text">
                            <p></p>
                        </div>
                
            </div>
        </div>
    </div>
                        </div><div class="item photo-b0a2c9b2-6655-11eb-aaa9-9725c0074053 hidden-print tnt-section-niche-pubs">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Royal Farms plans to build first NC store in Grandy","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html","uuid":"75cb564c-8988-5311-a1c0-053adacfebef","app":"editorial","metric":""}'  data-count="9"  class="photo-container layout-vertical">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="https://issuu.com/cookecommunicationsnc/docs/edass-021421?fr=sNTgyMzI5MzY3Njg" target="_blank" rel="noopener">
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Albemarle Business Directory 2021"
                    class="img-responsive owl-lazy default"
                    width="250"
                    height="265"
                    data-src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/b/0a/b0a2c9b2-6655-11eb-aaa9-9725c0074053/601af902a67af.preview.jpg" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-780362 collapse in">
                        <div class="card-headline caption-headline">
                            <h3 class="tnt-headline ">
        
             <a href="https://issuu.com/cookecommunicationsnc/docs/edass-021421?fr=sNTgyMzI5MzY3Njg" class="tnt-asset-link" target="_blank" rel="noopener" aria-label="Albemarle Business Directory 2021">
        

        
            Albemarle Business Directory 2021</a></h3>
                        </div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                            
                        </ul>
                    </div><div class="caption-text">
                            <p></p>
                        </div>
                
            </div>
        </div>
    </div>
                        </div><div class="item photo-afb2d08c-3401-11eb-920f-5bd76ac4926f hidden-print tnt-section-niche-pubs">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Royal Farms plans to build first NC store in Grandy","url":"/news/local/royal-farms-plans-to-build-first-nc-store-in-grandy/article_75cb564c-8988-5311-a1c0-053adacfebef.html","uuid":"75cb564c-8988-5311-a1c0-053adacfebef","app":"editorial","metric":""}'  data-count="10"  class="photo-container layout-square">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="https://issuu.com/cookecommunicationsnc/docs/updatededass-092720?fr=sODRjYTIzNzAxNjI" target="_blank" rel="noopener">
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Albemarle Health Care Directory"
                    class="img-responsive owl-lazy default"
                    width="250"
                    height="250"
                    data-src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/a/fb/afb2d08c-3401-11eb-920f-5bd76ac4926f/5fc689a39f80e.preview.jpg" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-780362 collapse in">
                        <div class="card-headline caption-headline">
                            <h3 class="tnt-headline ">
        
             <a href="https://issuu.com/cookecommunicationsnc/docs/updatededass-092720?fr=sODRjYTIzNzAxNjI" class="tnt-asset-link" target="_blank" rel="noopener" aria-label="Albemarle Health Care Directory">
        

        
            Albemarle Health Care Directory</a></h3>
                        </div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                            
                        </ul>
                    </div><div class="caption-text">
                            <p></p>
                        </div>
                
            </div>
        </div>
    </div>
                        </div>
            </template>
        </div>
        
        
            </div>
        </div>
        
    </div></section></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-780374" class="tncms-block"><a class="twitter-timeline" data-height="700" data-link-color="#1c3866" href="https://twitter.com/dailyadvance?ref_src=twsrc%5Etfw">Tweets by dailyadvance</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div><div id="tncms-block-827672" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-827672" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-827672');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-780372" class="tncms-block"><div class="fb-page" data-href="https://www.facebook.com/thedailyadvance" data-tabs="timeline" data-width="340" data-height="500" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/thedailyadvance" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/thedailyadvance">The Daily Advance</a></blockquote></div><p><br></p></div><div id="tncms-block-827689" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-827689" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-827689');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-777821" class="tncms-block"><section id="block-777821" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-777821 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-777821" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-777821" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
        
        
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-777821" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/news/local/ecsu-delays-start-of-spring-semester-until-jan-18/article_26640f79-5d20-5292-b1dc-3589e33c2d0c.html">ECSU delays start of spring semester until Jan. 18</a></li><li><a href="/news/local/currituck-gives-final-approval-to-new-subdivision-despite-school-crowding-concerns/article_d95f4362-4523-5948-9aae-92302bd51f66.html">Currituck gives final approval to new subdivision despite school crowding concerns</a></li><li><a href="/chowan/news/local/inner-banks-bbq-holds-official-opening-in-edenton/article_a78efd08-8f51-595e-8176-69fb75b33f98.html">Inner Banks BBQ holds official opening in Edenton</a></li><li><a href="/news/local/bertie-man-who-supplied-illegal-drugs-to-region-sentenced-to-25-years-in-fed-prison/article_06a17ddd-b9d4-5319-99a7-e1a6e421a88f.html">Bertie man who supplied illegal drugs to region sentenced to 25 years in fed prison</a></li><li><a href="/bertie/news/local/bertie-county-woman-bags-150-000-on-scratch-off/article_f62ea6be-6540-53b0-bfd4-788a04a2655c.html">Bertie County woman bags $150,000 on scratch-off</a></li><li><a href="/news/local/welcome-wade-wade-riley-lucero-first-baby-born-at-samc-in-new-year/article_41ddb3fb-7603-5f90-9fea-c6c138bae34c.html">Welcome, Wade!: Wade Riley Lucero first baby born at SAMC in new year</a></li><li><a href="/news/crime/camden-sheriff-arrests-ec-man-on-drug-charges/article_7e751e18-2bb4-5f1b-a454-c930ded4ecfb.html">Camden sheriff arrests EC man on drug charges</a></li><li><a href="/news/local/no-injuries-in-ambulance-rollover-in-camden-high-winds-blamed/article_e9f45008-db8f-5970-ba82-e696b67c7d98.html">No injuries in ambulance rollover in Camden; high winds blamed</a></li><li><a href="/news/local/rest-easy-chief-hundreds-remember-crawford-vfd-leader/article_81488983-6a27-5fa5-87d1-c531c71a2ddb.html">'Rest easy chief': Hundreds remember Crawford VFD leader</a></li><li><a href="/features/school_news/ecsu-grads-complete-internships-get-jobs-with-tech-firm/article_ad27c9aa-f9c7-5552-b65f-f2574618aab2.html">ECSU grads complete internships, get jobs with tech firm</a></li></ul></div>
        
        
            <div id="images-777821" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/film-review---the-355/image_c47168ed-4fe1-5399-a6aa-3bf883e90f95.html" class="tnt-asset-link"  aria-label="Film Review - The 355">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Film Review - The 355"
                            class="img-responsive lazyload ap-photo full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/47/c47168ed-4fe1-5399-a6aa-3bf883e90f95/61cef2012e521.image.jpg?crop=1175%2C1175%2C294%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/47/c47168ed-4fe1-5399-a6aa-3bf883e90f95/61cef2012e521.image.jpg?crop=1175%2C1175%2C294%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/47/c47168ed-4fe1-5399-a6aa-3bf883e90f95/61cef2012e521.image.jpg?crop=1175%2C1175%2C294%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/47/c47168ed-4fe1-5399-a6aa-3bf883e90f95/61cef2012e521.image.jpg?crop=1175%2C1175%2C294%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/47/c47168ed-4fe1-5399-a6aa-3bf883e90f95/61cef2012e521.image.jpg?crop=1175%2C1175%2C294%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/47/c47168ed-4fe1-5399-a6aa-3bf883e90f95/61cef2012e521.image.jpg?crop=1175%2C1175%2C294%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/47/c47168ed-4fe1-5399-a6aa-3bf883e90f95/61cef2012e521.image.jpg?crop=1175%2C1175%2C294%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/47/c47168ed-4fe1-5399-a6aa-3bf883e90f95/61cef2012e521.image.jpg?crop=1175%2C1175%2C294%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/47/c47168ed-4fe1-5399-a6aa-3bf883e90f95/61cef2012e521.image.jpg?crop=1175%2C1175%2C294%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/47/c47168ed-4fe1-5399-a6aa-3bf883e90f95/61cef2012e521.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/c/47/c47168ed-4fe1-5399-a6aa-3bf883e90f95/61cef2012e521.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/la-premiere-of-spider-man-no-way-home/image_3344f432-eae7-5fc8-8d3a-5621c68bf7f1.html" class="tnt-asset-link"  aria-label="LA Premiere of &quot;Spider-Man: No Way Home&quot;">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="LA Premiere of &quot;Spider-Man: No Way Home&quot;"
                            class="img-responsive lazyload ap-photo full default"
                            width="1169"
                            height="1169"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/34/3344f432-eae7-5fc8-8d3a-5621c68bf7f1/61b805bd192a7.image.jpg?crop=1169%2C1169%2C0%2C301&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/34/3344f432-eae7-5fc8-8d3a-5621c68bf7f1/61b805bd192a7.image.jpg?crop=1169%2C1169%2C0%2C301&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/34/3344f432-eae7-5fc8-8d3a-5621c68bf7f1/61b805bd192a7.image.jpg?crop=1169%2C1169%2C0%2C301&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/34/3344f432-eae7-5fc8-8d3a-5621c68bf7f1/61b805bd192a7.image.jpg?crop=1169%2C1169%2C0%2C301&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/34/3344f432-eae7-5fc8-8d3a-5621c68bf7f1/61b805bd192a7.image.jpg?crop=1169%2C1169%2C0%2C301&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/34/3344f432-eae7-5fc8-8d3a-5621c68bf7f1/61b805bd192a7.image.jpg?crop=1169%2C1169%2C0%2C301&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/34/3344f432-eae7-5fc8-8d3a-5621c68bf7f1/61b805bd192a7.image.jpg?crop=1169%2C1169%2C0%2C301&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/34/3344f432-eae7-5fc8-8d3a-5621c68bf7f1/61b805bd192a7.image.jpg?crop=1169%2C1169%2C0%2C301&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/34/3344f432-eae7-5fc8-8d3a-5621c68bf7f1/61b805bd192a7.image.jpg?crop=1169%2C1169%2C0%2C301&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/34/3344f432-eae7-5fc8-8d3a-5621c68bf7f1/61b805bd192a7.image.jpg?crop=1169%2C1169%2C0%2C301&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/3/34/3344f432-eae7-5fc8-8d3a-5621c68bf7f1/61b805bd192a7.image.jpg?crop=1169%2C1169%2C0%2C301&resize=1169%2C1169&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/world/venezuela-santa-run/image_eacd1f53-0a46-5d7c-9461-834458c2244c.html" class="tnt-asset-link"  aria-label="Venezuela Santa Run">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Venezuela Santa Run"
                            class="img-responsive lazyload ap-photo full default"
                            width="1176"
                            height="1176"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/ac/eacd1f53-0a46-5d7c-9461-834458c2244c/61bf81e290896.image.jpg?crop=1176%2C1176%2C293%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/ac/eacd1f53-0a46-5d7c-9461-834458c2244c/61bf81e290896.image.jpg?crop=1176%2C1176%2C293%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/ac/eacd1f53-0a46-5d7c-9461-834458c2244c/61bf81e290896.image.jpg?crop=1176%2C1176%2C293%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/ac/eacd1f53-0a46-5d7c-9461-834458c2244c/61bf81e290896.image.jpg?crop=1176%2C1176%2C293%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/ac/eacd1f53-0a46-5d7c-9461-834458c2244c/61bf81e290896.image.jpg?crop=1176%2C1176%2C293%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/ac/eacd1f53-0a46-5d7c-9461-834458c2244c/61bf81e290896.image.jpg?crop=1176%2C1176%2C293%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/ac/eacd1f53-0a46-5d7c-9461-834458c2244c/61bf81e290896.image.jpg?crop=1176%2C1176%2C293%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/ac/eacd1f53-0a46-5d7c-9461-834458c2244c/61bf81e290896.image.jpg?crop=1176%2C1176%2C293%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/ac/eacd1f53-0a46-5d7c-9461-834458c2244c/61bf81e290896.image.jpg?crop=1176%2C1176%2C293%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/ac/eacd1f53-0a46-5d7c-9461-834458c2244c/61bf81e290896.image.jpg?crop=1176%2C1176%2C293%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/e/ac/eacd1f53-0a46-5d7c-9461-834458c2244c/61bf81e290896.image.jpg?crop=1176%2C1176%2C293%2C0&resize=1176%2C1176&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/world/venezuela-santa-run/image_8c8c32dc-02fd-5cc3-a988-c8bda8fe50f3.html" class="tnt-asset-link"  aria-label="Venezuela Santa Run">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Venezuela Santa Run"
                            class="img-responsive lazyload ap-photo full default"
                            width="1176"
                            height="1176"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c8/8c8c32dc-02fd-5cc3-a988-c8bda8fe50f3/61bf81ef06291.image.jpg?crop=1176%2C1176%2C293%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c8/8c8c32dc-02fd-5cc3-a988-c8bda8fe50f3/61bf81ef06291.image.jpg?crop=1176%2C1176%2C293%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c8/8c8c32dc-02fd-5cc3-a988-c8bda8fe50f3/61bf81ef06291.image.jpg?crop=1176%2C1176%2C293%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c8/8c8c32dc-02fd-5cc3-a988-c8bda8fe50f3/61bf81ef06291.image.jpg?crop=1176%2C1176%2C293%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c8/8c8c32dc-02fd-5cc3-a988-c8bda8fe50f3/61bf81ef06291.image.jpg?crop=1176%2C1176%2C293%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c8/8c8c32dc-02fd-5cc3-a988-c8bda8fe50f3/61bf81ef06291.image.jpg?crop=1176%2C1176%2C293%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c8/8c8c32dc-02fd-5cc3-a988-c8bda8fe50f3/61bf81ef06291.image.jpg?crop=1176%2C1176%2C293%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c8/8c8c32dc-02fd-5cc3-a988-c8bda8fe50f3/61bf81ef06291.image.jpg?crop=1176%2C1176%2C293%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c8/8c8c32dc-02fd-5cc3-a988-c8bda8fe50f3/61bf81ef06291.image.jpg?crop=1176%2C1176%2C293%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c8/8c8c32dc-02fd-5cc3-a988-c8bda8fe50f3/61bf81ef06291.image.jpg?crop=1176%2C1176%2C293%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/8/c8/8c8c32dc-02fd-5cc3-a988-c8bda8fe50f3/61bf81ef06291.image.jpg?crop=1176%2C1176%2C293%2C0&resize=1176%2C1176&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/kevin-mccord/image_0a23c4d3-3463-51b3-8218-8e92fd034955.html" class="tnt-asset-link"  aria-label="Kevin McCord">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Kevin McCord"
                            class="img-responsive lazyload full default"
                            width="342"
                            height="342"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/0/a2/0a23c4d3-3463-51b3-8218-8e92fd034955/61cce747eceed.image.jpg?crop=342%2C342%2C0%2C48&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/0/a2/0a23c4d3-3463-51b3-8218-8e92fd034955/61cce747eceed.image.jpg?crop=342%2C342%2C0%2C48&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/0/a2/0a23c4d3-3463-51b3-8218-8e92fd034955/61cce747eceed.image.jpg?crop=342%2C342%2C0%2C48&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/0/a2/0a23c4d3-3463-51b3-8218-8e92fd034955/61cce747eceed.image.jpg?crop=342%2C342%2C0%2C48&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/0/a2/0a23c4d3-3463-51b3-8218-8e92fd034955/61cce747eceed.image.jpg?crop=342%2C342%2C0%2C48&resize=342%2C342&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/new-years-eve-times-square/image_5db3691b-5be4-5baf-9b18-61f31ffaf007.html" class="tnt-asset-link"  aria-label="New Years Eve Times Square">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="New Years Eve Times Square"
                            class="img-responsive lazyload ap-photo full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/5/db/5db3691b-5be4-5baf-9b18-61f31ffaf007/61ce506175655.image.jpg?crop=1175%2C1175%2C294%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/5/db/5db3691b-5be4-5baf-9b18-61f31ffaf007/61ce506175655.image.jpg?crop=1175%2C1175%2C294%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/5/db/5db3691b-5be4-5baf-9b18-61f31ffaf007/61ce506175655.image.jpg?crop=1175%2C1175%2C294%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/5/db/5db3691b-5be4-5baf-9b18-61f31ffaf007/61ce506175655.image.jpg?crop=1175%2C1175%2C294%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/5/db/5db3691b-5be4-5baf-9b18-61f31ffaf007/61ce506175655.image.jpg?crop=1175%2C1175%2C294%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/5/db/5db3691b-5be4-5baf-9b18-61f31ffaf007/61ce506175655.image.jpg?crop=1175%2C1175%2C294%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/5/db/5db3691b-5be4-5baf-9b18-61f31ffaf007/61ce506175655.image.jpg?crop=1175%2C1175%2C294%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/5/db/5db3691b-5be4-5baf-9b18-61f31ffaf007/61ce506175655.image.jpg?crop=1175%2C1175%2C294%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/5/db/5db3691b-5be4-5baf-9b18-61f31ffaf007/61ce506175655.image.jpg?crop=1175%2C1175%2C294%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/5/db/5db3691b-5be4-5baf-9b18-61f31ffaf007/61ce506175655.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/5/db/5db3691b-5be4-5baf-9b18-61f31ffaf007/61ce506175655.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/nhs-dec-2021-1/image_25a3fc95-da9b-5a63-97c9-6756a067e3fc.html" class="tnt-asset-link"  aria-label="NHS Dec. 2021 1">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="NHS Dec. 2021 1"
                            class="img-responsive lazyload full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/5a/25a3fc95-da9b-5a63-97c9-6756a067e3fc/61c4ead5d09bd.image.jpg?crop=1175%2C1175%2C310%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/5a/25a3fc95-da9b-5a63-97c9-6756a067e3fc/61c4ead5d09bd.image.jpg?crop=1175%2C1175%2C310%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/5a/25a3fc95-da9b-5a63-97c9-6756a067e3fc/61c4ead5d09bd.image.jpg?crop=1175%2C1175%2C310%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/5a/25a3fc95-da9b-5a63-97c9-6756a067e3fc/61c4ead5d09bd.image.jpg?crop=1175%2C1175%2C310%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/5a/25a3fc95-da9b-5a63-97c9-6756a067e3fc/61c4ead5d09bd.image.jpg?crop=1175%2C1175%2C310%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/5a/25a3fc95-da9b-5a63-97c9-6756a067e3fc/61c4ead5d09bd.image.jpg?crop=1175%2C1175%2C310%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/5a/25a3fc95-da9b-5a63-97c9-6756a067e3fc/61c4ead5d09bd.image.jpg?crop=1175%2C1175%2C310%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/5a/25a3fc95-da9b-5a63-97c9-6756a067e3fc/61c4ead5d09bd.image.jpg?crop=1175%2C1175%2C310%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/5a/25a3fc95-da9b-5a63-97c9-6756a067e3fc/61c4ead5d09bd.image.jpg?crop=1175%2C1175%2C310%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/5a/25a3fc95-da9b-5a63-97c9-6756a067e3fc/61c4ead5d09bd.image.jpg?crop=1175%2C1175%2C310%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/5a/25a3fc95-da9b-5a63-97c9-6756a067e3fc/61c4ead5d09bd.image.jpg?crop=1175%2C1175%2C310%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/world/brazil-deadly-cliff-collapse/image_25263edd-96d9-59c0-a50d-9f25175fe50d.html" class="tnt-asset-link"  aria-label="Brazil Deadly Cliff Collapse">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Brazil Deadly Cliff Collapse"
                            class="img-responsive lazyload ap-photo full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/52/25263edd-96d9-59c0-a50d-9f25175fe50d/61d9f57c08fe3.image.jpg?crop=1175%2C1175%2C294%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/52/25263edd-96d9-59c0-a50d-9f25175fe50d/61d9f57c08fe3.image.jpg?crop=1175%2C1175%2C294%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/52/25263edd-96d9-59c0-a50d-9f25175fe50d/61d9f57c08fe3.image.jpg?crop=1175%2C1175%2C294%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/52/25263edd-96d9-59c0-a50d-9f25175fe50d/61d9f57c08fe3.image.jpg?crop=1175%2C1175%2C294%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/52/25263edd-96d9-59c0-a50d-9f25175fe50d/61d9f57c08fe3.image.jpg?crop=1175%2C1175%2C294%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/52/25263edd-96d9-59c0-a50d-9f25175fe50d/61d9f57c08fe3.image.jpg?crop=1175%2C1175%2C294%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/52/25263edd-96d9-59c0-a50d-9f25175fe50d/61d9f57c08fe3.image.jpg?crop=1175%2C1175%2C294%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/52/25263edd-96d9-59c0-a50d-9f25175fe50d/61d9f57c08fe3.image.jpg?crop=1175%2C1175%2C294%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/52/25263edd-96d9-59c0-a50d-9f25175fe50d/61d9f57c08fe3.image.jpg?crop=1175%2C1175%2C294%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/52/25263edd-96d9-59c0-a50d-9f25175fe50d/61d9f57c08fe3.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/2/52/25263edd-96d9-59c0-a50d-9f25175fe50d/61d9f57c08fe3.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/world/portugal-big-wave-surfing/image_17b5ecad-00a9-5e85-be72-8115ab1b655c.html" class="tnt-asset-link"  aria-label="Portugal Big Wave Surfing">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Portugal Big Wave Surfing"
                            class="img-responsive lazyload ap-photo full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/1/7b/17b5ecad-00a9-5e85-be72-8115ab1b655c/61d9a7650fa84.image.jpg?crop=1175%2C1175%2C295%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/1/7b/17b5ecad-00a9-5e85-be72-8115ab1b655c/61d9a7650fa84.image.jpg?crop=1175%2C1175%2C295%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/1/7b/17b5ecad-00a9-5e85-be72-8115ab1b655c/61d9a7650fa84.image.jpg?crop=1175%2C1175%2C295%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/1/7b/17b5ecad-00a9-5e85-be72-8115ab1b655c/61d9a7650fa84.image.jpg?crop=1175%2C1175%2C295%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/1/7b/17b5ecad-00a9-5e85-be72-8115ab1b655c/61d9a7650fa84.image.jpg?crop=1175%2C1175%2C295%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/1/7b/17b5ecad-00a9-5e85-be72-8115ab1b655c/61d9a7650fa84.image.jpg?crop=1175%2C1175%2C295%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/1/7b/17b5ecad-00a9-5e85-be72-8115ab1b655c/61d9a7650fa84.image.jpg?crop=1175%2C1175%2C295%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/1/7b/17b5ecad-00a9-5e85-be72-8115ab1b655c/61d9a7650fa84.image.jpg?crop=1175%2C1175%2C295%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/1/7b/17b5ecad-00a9-5e85-be72-8115ab1b655c/61d9a7650fa84.image.jpg?crop=1175%2C1175%2C295%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/1/7b/17b5ecad-00a9-5e85-be72-8115ab1b655c/61d9a7650fa84.image.jpg?crop=1175%2C1175%2C295%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/1/7b/17b5ecad-00a9-5e85-be72-8115ab1b655c/61d9a7650fa84.image.jpg?crop=1175%2C1175%2C295%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/world/portugal-big-wave-surfing/image_f5f5dfbe-b08c-5a47-b723-af955c29d430.html" class="tnt-asset-link"  aria-label="Portugal Big Wave Surfing">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Portugal Big Wave Surfing"
                            class="img-responsive lazyload ap-photo full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/f/5f/f5f5dfbe-b08c-5a47-b723-af955c29d430/61d9a76676310.image.jpg?crop=1175%2C1175%2C294%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/f/5f/f5f5dfbe-b08c-5a47-b723-af955c29d430/61d9a76676310.image.jpg?crop=1175%2C1175%2C294%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/f/5f/f5f5dfbe-b08c-5a47-b723-af955c29d430/61d9a76676310.image.jpg?crop=1175%2C1175%2C294%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/f/5f/f5f5dfbe-b08c-5a47-b723-af955c29d430/61d9a76676310.image.jpg?crop=1175%2C1175%2C294%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/f/5f/f5f5dfbe-b08c-5a47-b723-af955c29d430/61d9a76676310.image.jpg?crop=1175%2C1175%2C294%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/f/5f/f5f5dfbe-b08c-5a47-b723-af955c29d430/61d9a76676310.image.jpg?crop=1175%2C1175%2C294%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/f/5f/f5f5dfbe-b08c-5a47-b723-af955c29d430/61d9a76676310.image.jpg?crop=1175%2C1175%2C294%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/f/5f/f5f5dfbe-b08c-5a47-b723-af955c29d430/61d9a76676310.image.jpg?crop=1175%2C1175%2C294%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/f/5f/f5f5dfbe-b08c-5a47-b723-af955c29d430/61d9a76676310.image.jpg?crop=1175%2C1175%2C294%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/f/5f/f5f5dfbe-b08c-5a47-b723-af955c29d430/61d9a76676310.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/content/tncms/assets/v3/editorial/f/5f/f5f5dfbe-b08c-5a47-b723-af955c29d430/61d9a76676310.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        
        
        
        
    </div>
</div></section></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-777763" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-777763" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-777763');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-783415" class="tncms-block"><section id="block-783415" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-783415 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div></section></div><div id="tncms-block-783413" class="tncms-block"><p><img style="float:right;width:25%;" src="/content/tncms/custom/image/26b0d57e-91d0-11e9-95ba-13d6ae0637d3.png"><b>www.DailyAdvance.com</b><br>
1016 W Ehringhaus St<br>
Elizabeth City, NC 27909<br><b>Main Phone: </b>252-335-0841<br><b>Customer Care Phone: </b>252-329-9505<br></p></div></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-777812" class="tncms-block"><section id="block-777812" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-777812 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="https://www.dailyadvance.com/site/about.html"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="https://www.dailyadvance.com/site/contact.html"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscription-portal"  href="https://apg01.newzware.com/ss70v2/enc/common/template.jsp"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Subscription Portal</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscription-terms"  href="/site/subscription_terms.html"  tabindex="0">
                    <span class="nav-label">Subscription Terms</span>
                </a></li><li>
                <a class="nav-link   tnt-section-password-reset"  href="https://apg01.newzware.com/ss70v2/enc/common/template.jsp"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Password Reset</span>
                </a></li><li>
                <a class="nav-link   tnt-section-refund-policy"  href="/site/refund_policy.html"  tabindex="0">
                    <span class="nav-label">Refund Policy</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1008528" class="tncms-block"><section id="block-1008528" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1008528 ">
        <div class="block-title-inner">
            <h4>
                
                Submission Forms
                
            </h4>
        </div>
    </div></div></section></div><div id="tncms-block-1008529" class="tncms-block"><h4><a href="https://www.cognitoforms.com/APGEasternNC/APGENCDeliveryIssues" target="_blank">Delivery Issues</a></h4></div></div><div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=DAILYADVANCE&amp;publisher_url:dailyadvance.com#/quick"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Promote Your Event</span>
                </a></li><li>
                <a class="nav-link   tnt-section-letter-to-editor"  href="/site/forms/online_services/letter_editor"  tabindex="0">
                    <span class="nav-label">Letter To Editor</span>
                </a></li></ul></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                

    

            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-777816" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-777816"><div class="col-md-7"><small>&#169; Copyright 2021 APG East LLC. All rights reserved </small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    <div id="sticky-anchor"><div id="tncms-region-page_sticky_anchor" class="tncms-region hidden-print collapse in"><div id="tncms-block-1039458" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1039458" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" data-mobile-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1039458');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("75cb564c-8988-5311-a1c0-053adacfebef")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc16235.add('act', dmpData);_cc16235.bcp();
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': ["news/local"],
            'tncms.asset.flags': [""],
            'tncms.asset.keywords': [""]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.google.survey.f62819b485e5f0a32cee78210d157aca.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.f6ff781b3dbbba2bc5525f04566853df.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.granted.697bbb21056c63b56789e404bb4fa8a7.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.denied.63a83f5bb281eac870c3c9e1091b2729.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                                    $('#weather_zip_toggle_777874').click(function(e){
                                        $('#weather-777874 .zip-update-form').toggle('fast');
                                        return false; 
                                    });
                                }); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.fa820af8c4b7651b60faff4dca7ed722.js"></script>
<script>/*<![CDATA[*/ function articleShareSticky(){
                setTimeout(function(){
                    var sMainTop = document.querySelector('#main-body-container').offsetTop,
                        oNavBar = document.querySelector('#site-navbar-container');
                    if (sMainTop < window.scrollY){
                        oNavBar.classList.add('article-share')
                    } else {
                        oNavBar.classList.remove('article-share')
                    }
                }, 150)
            }
            document.addEventListener('scroll', articleShareSticky); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/dailyadvance.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.54d9f15b0d238de6bb20ec82ed8307ac.js"></script>
<script>/*<![CDATA[*/ __tnt.regions.stickyAnchor.init(); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            _cc16235.add('act', serviceData);_cc16235.bcp();
                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc16235.add('act', dmpData);_cc16235.bcp();
                    }
                }
            }
         /*]]>*/</script></body>
</html>